Unfortunately, this has been further delayed until ~18 CEST due to delays on their end. We deeply regret this delay and will evaluate then on if local traffic levels allow for setting the location live today.
Posted Oct 20, 2025 - 15:10 UTC
Update
Unfortunately, this is delayed until ~16:30 CEST due to an incomplete config on our upstreams side
Posted Oct 20, 2025 - 13:39 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 20, 2025 - 13:09 UTC
Scheduled
We will be undergoing scheduled implementation of the New York City location during this time. Game Shield customers may experience a brief disconnect in sessions around the area when BGP converges.
No further issues are expected. This is as well done at low traffic times local to NYC.
Thank you for your understanding, contact support should you notice any issues.
Posted Oct 19, 2025 - 21:47 UTC
This scheduled maintenance affected: Network Edge Locations (NYC - New York City Edge Network).