Latency Issues in US

Incident Report for NeoProtect

Resolved

This incident has been resolved.
Posted May 15, 2025 - 17:57 UTC

Monitoring

While no further occurrance has been monitored, we are actively and solely monitoring this issue now. An additional fix has been deployed and we are awaiting the outcome.
Posted May 13, 2025 - 15:56 UTC

Identified

Our core team is further working on this incident, we will update you here and via support.
Posted May 13, 2025 - 15:42 UTC

Monitoring

The issue has not re-occurred since 2025-05-13 05:04:00 CET and our network team has implemented measurements against the root cause. Further information will follow.
Posted May 13, 2025 - 09:03 UTC

Update

Multiple US regions are currently experiencing high latency and connectivity issues. Our team is actively investigating and working to resolve the situation as quickly as possible.
Posted May 13, 2025 - 03:43 UTC

Investigating

We’ve received multiple reports of elevated latency affecting our Dallas PoP. Our on-call engineering team has been notified.
Posted May 13, 2025 - 03:05 UTC
This incident affected: Network Edge Locations (ASH - Ashburn Edge Network, MIA - Miami Edge Network, CHI - Chicago Edge Network, DAL - Dallas Edge Network, LAX - Los Angeles Edge Network).