Packet loss incident observed on multiple edge locations

Incident Report for NeoProtect

Resolved

This incident is resolved.

The incident was related to major Multi-terabit attacks targeting 15+ /24 ranges simultaneously with attack sources across the globe; the attack in itself being of sophisticated nature.

At this time, we don't expect further incidents occurring however are working on further optimizations to fully rule out impact on such occurrances going forward.

We have both responded to live occurrances with immediate update responses along with testing such in a development environment by simulating the attacks at hand and verifying correct responses by failsafe systems.

We understand the severity and urgency of such incidents and the importance of them being resolved entirely going forward.
In response, we have ordered an additional near 2 Tbit/s of Upstream capacity with CDN77 on an emergency basis for primary points of impact. The majority in EU/US but as well upgrades in SGP.
The ETA given by our upstream for the deployment of such upgrades is 1-4 days globally.

The team is preparing for emergency maintenances and is ensuring pre-emptively that a smooth overall maintenance operation can be guaranteed.
Maintenance windows will be announced 24 hours beforehand and are, as timing allows, done at best possible times in terms of low traffic and technician availability in each respective location.
Support staff will be available throughout such maintenance windows along with immediate and prepared escalation processes.
We will reach out to customers without backup tunnels or alternative redundancy who would be affected by this maintenance accordingly.

Thank you for your incredible support and understanding throughout such tough times. We are happy to assist in answering any question you may have through our usual support channels.
Posted Aug 27, 2025 - 16:21 UTC

Monitoring

We have deployed an apparent fix for this and are working to confirm it in parallel to monitoring at this time
Posted Aug 26, 2025 - 20:02 UTC

Investigating

Our core team is actively investigating and handling the issue
Posted Aug 26, 2025 - 19:43 UTC
This incident affected: Network Edge Locations (FRA - Frankfurt Edge Network, AMS - Amsterdam Edge Network, BUC - Bucharest Edge Network, PAR - Paris Edge Network, WAW - Warsaw Edge Network, MAD - Madrid Edge Network, MRS - Marseille Edge Network, ASH - Ashburn Edge Network, MIA - Miami Edge Network, CHI - Chicago Edge Network, DAL - Dallas Edge Network, LAX - Los Angeles Edge Network, SGP - Singapore Edge Network, HKG - Hong Kong Edge Network, TYO - Tokyo Edge Network, SEA - Seattle Edge Network, LON - London Edge Network).