Their official response is "We experienced degraded connection quality on some paths due to an unexpected issue with a core router in our Frankfurt data center. The issue occurred from 20:35 to 21:00 UTC and has since been resolved.". They also mentioned that this was a similar issue to the one that occured in Singapore ( https://neoprotect.statuspage.io/incidents/vylj4wc6zqn3 )
We will further gather information about the origin of the issue, which will then be posted in a post-mortem. However, we do not expect any issues re-occuring at this time. Thank you for your understanding. Contact support should you continue to experience any issues.
Posted Apr 01, 2025 - 21:21 UTC
Update
We are not seeing any further issues occurring still, yet lack a detailed explanation from our Upstream. They stated "We are experiencing global network issues. We are working on the solution." with the incident title being "Ongoing connectivity outage in Frankfurt".
We will update you here as soon as we know more. Please contact our support via an urgent technical ticket in our panel, should you still experience any issues.
Posted Apr 01, 2025 - 21:07 UTC
Monitoring
Our Upstream confirmed the issue is on their side and only known to exist in Frankfurt. We expect routes ingressing via Frankfurt to have been affected as well. Until now, the issue has not re-occurred.
We have observed the issue to start occurring as of 2025-04-01 22:35:00 CET and have it seen recovering as of 2025-04-01 22:36:28 CET. The issue has not refaced since.
Posted Apr 01, 2025 - 20:49 UTC
Update
We are continuing to investigate, however do not see any attack-related, hardware related or software related issues at this time and suspect a problem with our primary Upstream. We will keep you up-to-date here. There are potentially more locations/locations around Frankfurt that are partially impacted.